Author Topic: Script error:no matching prefabs for: joiner  (Read 169 times)

Gadavre

  • Posts: 52
Script error:no matching prefabs for: joiner
« on: August 16, 2017, 06:22:44 AM »
please help!!! :'(
 i  have in 7.666 Script error:no matching prefabs for: joiner




My System: windows 7 64-bit

« Last Edit: August 17, 2017, 09:38:54 AM by Gadavre »

andrewj

  • Developer
  • *****
  • Posts: 1490
Re: Script error:no matching prefabs for: joiner
« Reply #1 on: August 16, 2017, 07:02:27 AM »
Please post your settings, so I can test it here.

Click on "Menu" button, then "Config Manager" and then "Save" button.  It will save your settings to a file.  Use the "Attachments" feature of this forum to attach that file to your post.

Gadavre

  • Posts: 52
Re: Script error:no matching prefabs for: joiner
« Reply #2 on: August 16, 2017, 08:01:26 AM »
my settings

andrewj

  • Developer
  • *****
  • Posts: 1490
Re: Script error:no matching prefabs for: joiner
« Reply #3 on: August 16, 2017, 06:29:12 PM »
Thanks for posting your settings.

I can reproduce the issue here, so now I will investigate what is causing it.....

Gadavre

  • Posts: 52
Re: Script error:no matching prefabs for: joiner
« Reply #4 on: August 17, 2017, 09:26:29 AM »
I found some program settings that cause its error
If in my settings:
Length = Full Game
Steepness = None

so then I always have a bug in the program.
If :
Length = One Episode
i can see this bug or cant see it

andrewj

  • Developer
  • *****
  • Posts: 1490
Re: Script error:no matching prefabs for: joiner
« Reply #5 on: August 17, 2017, 11:45:34 PM »
Yes, using "Steepness" set to NONE will trigger the bug, since there is a lift joiner that can be used otherwise.

And it is more likely in "extreme" maps and/or in full games simply because they create more large joiners.  Though it can definitely happen in an episode or even a single map.

It also only occurs when theme of a map is not "tech", since the tech theme has joiners which can be used.

I will produce a hot-fix for this issue soon.

Gadavre

  • Posts: 52
Re: Script error:no matching prefabs for: joiner
« Reply #6 on: August 28, 2017, 06:32:49 AM »
I will produce a hot-fix for this issue soon.
This hot-fix will be in the new version of the Oblige? Look forward to this bug fix!