Author Topic: [FIXED] Oblige 6.10 doesnt generate strictly correct .wad files  (Read 959 times)

borg88

  • Posts: 12
Hello.

New oblige 6.10 doesnt generate strictly correct .wad files.
Many old WAD manipulation tools crash, or display incorrect files.
Problem is in MAP lumps. MAP name lump should have size=0
while oblige 6.1 MAP lump have size=1
This needs to be fixed.

Regards,
Borg
« Last Edit: July 25, 2014, 05:22:07 AM by andrewj »

De-M-oN

  • Posts: 126
Re: Oblige 6.10 doesnt generate strictly correct .wad files
« Reply #1 on: July 24, 2014, 01:33:25 PM »
How about not using a stoneage tool? :P

Glaice

  • Contributor
  • *****
  • Posts: 1154
  • Veteran OBLIGE modder
    • The Doom Video Vault
Re: Oblige 6.10 doesnt generate strictly correct .wad files
« Reply #2 on: July 24, 2014, 02:18:23 PM »
I have no issue loading a 6.10 WAD with XWE, SLADE or Doom Builder, what tools are you using Borg?

andrewj

  • Developer
  • *****
  • Posts: 1395
Re: Oblige 6.10 doesnt generate strictly correct .wad files
« Reply #3 on: July 25, 2014, 05:21:40 AM »
Bug confirmed, and has been fixed (in r11657).

I also moved this thread into the Bug Reports section of the forum.

borg88

  • Posts: 12
Re: [FIXED] Oblige 6.10 doesnt generate strictly correct .wad files
« Reply #4 on: July 25, 2014, 10:13:48 AM »
andrewj: thx :)

Glaice:
Well, im using Game Archive Unpacker (TC plugin).
ZETH doesnt like wads like that too.